Tags

, ,

To remember the steps required to define multiple SSID in Autonomous AP, I have used following comparison between logical segmentation (VLANs) in wired environment & SSID config in Autonomous AP.

Step

Layer 2 Switch

Autonomous Access Points

1

Define Vlans (3 vlans defined. Vlan 110 for Management, 12 & 13 for user data)

Define SSID with associated vlan numbers.

  vlan 12
name HQData1
!
vlan 13
HQData2
!
vlan 110
Management
!
int x/x  <—- where x/x is the Trunk to Uplink switch.
switchport trunk encapsulation dot1q
switchport trunk native vlan 999
switchport mode trunk
dot11 ssid HQData1 <- Vlan name use as SSID for the simplicity.
vlan 12
authentication open
mbssid guest-mode <– Only required multiple SSID to be broadcast. If it is only single SSID this needs to be “ ssid guest-mode”!
dot11 ssid HQData2
vlan 13
authentication open
authentication key-management wpa version 2
mbssid guest-mode
wpa-psk ascii Cisco123
2 Configure the SW Mgt Interface Configure the  BVI  Interface
  int vlan 100
ip add 10.10.110.100 255.255.255.0
interface BVI1
ip address 10.10.110.100 255.255.255.0
!
interface GigabitEthernet0.110
encapsulation dot1Q 110
bridge-group 1   <—– BVI does not support Bridge-group. So it should be bridge-group 1 here.
3 Define Default Gateway Define Default Gateway
  ip default-gateway 10.10.110.1 ip default-gateway 10.10.110.1
4   Create Ethernet & Radio sub-interface
  interface GigabitEthernet0.12
encapsulation dot1Q 12
bridge-group 12 <—— Bridge Group number is value between [1-255]
!
interface GigabitEthernet0.13
encapsulation dot1Q 13
bridge-group 13interface Dot11Radio1.12  <— Dot11Radio1 for 5GHz & Dot11Radio0 for 2.4GHz band. In this example only configure 5GHz.
encapsulation dot1Q 12
bridge-group 12
!
interface Dot11Radio1.13
encapsulation dot1Q 13
bridge-group 13
5   Assigning SSID to Radio Interfaces
  interface Dot11Radio1 <- Only 5GHz band use for this example
encryption vlan 13 mode ciphers aes-ccm
ssid HQData1
ssid HQData2
mbssid

Following links may be useful as discuss the same topic.

https://supportforums.cisco.com/videos/2343

https://supportforums.cisco.com/docs/DOC-14496