In this post we will see the Queuing models available on this 3850 switch platforms. Due to the nature of Converged Access, there are separate queuing models for wired & wireless ports (any port directly attached to an AP)
A wireless port will provide 4 independent queues & in contrast a wired port will provide upto 8 queues. This 8 queue models will closely align with 4500/6500 queuing architecture & therefore much easier to align with QoS policies.
Basic architecture of this platform provides 24x1G access ports & 2x10G uplinks per ASIC (Application Specific Integrated Circuit) to 120G stack connection.(In 48 port switch has 2x ASIC). This also provide two seperate internal queues over the stack ring, giving access to the priority traffic & non-priority traffic. Ingress queuing is not configurable. Below diagram provide basic stack architecture of this platform.
In Egress Queuing, we can discuss this as Wired Egress & Wireless Egress queuing separately as queuing model is different in each scenario.
1. Wired Queuing
Egress wired queuing on the 3850 can be configured as 8Q3T, 1P7Q3T or 2P6Q3T. Since first one does not have priority queuing it is not recommended. If your core/distribution is having 4500/6500 platforms both share the 1P7Q3T model, so if you using 3850, you can easily align policies with your core/distribution.
- 1P7Q3T : Below diagram illustrate the 1P7Q3T egress queue mappings for a 3850 using 8-class model. The recommended buffer allocations for wired interface queues 7 through 1 are 10%, 10% 10%, 10%,10%, 10%,25%. By using “queue buffer-ratio” command you can configure this.
Below show the corresponding configuration for an 8-class 1P7Q3T egress queuing on a 3850.
C3850(config-pmap-c)# policy-map 1P7Q3T C3850(config-pmap)# class VOICE C3850(config-pmap-c)# priority level 1 C3850(config-pmap-c)# police rate percent 10 ! C3850(config-pmap-c-police)# class NW-CONTROL C3850(config-pmap-c)# bandwidth remaining percent 5 C3850(config-pmap-c)# queue-buffers ratio 10 ! C3850(config-pmap-c)# class INT-VIDEO C3850(config-pmap-c)# bandwidth remaining percent 23 C3850(config-pmap-c)# queue-buffers ratio 10 C3850(config-pmap-c)# queue-limit dscp af43 percent 80 C3850(config-pmap-c)# queue-limit dscp af42 percent 90 C3850(config-pmap-c)# queue-limit dscp af41 percent 100 ! C3850(config-pmap)# class SIGNALING C3850(config-pmap-c)# bandwidth remaining percent 2 ! C3850(config-pmap-c)# class STREAMING-VIDEO C3850(config-pmap-c)# bandwidth remaining percent 10 C3850(config-pmap-c)# queue-buffers ratio 10 C3850(config-pmap-c)# queue-limit dscp af33 percent 80 C3850(config-pmap-c)# queue-limit dscp af32 percent 90 C3850(config-pmap-c)# queue-limit dscp af31 percent 100 ! C3850(config-pmap-c)# class CRITICAL-DATA C3850(config-pmap-c)# bandwidth remaining percent 24 C3850(config-pmap-c)# queue-buffers ratio 10 C3850(config-pmap-c)# queue-limit dscp af23 percent 80 C3850(config-pmap-c)# queue-limit dscp af22 percent 90 C3850(config-pmap-c)# queue-limit dscp af21 percent 100 ! C3850(config-pmap-c)# class SCAVENGER C3850(config-pmap-c)# bandwidth remaining percent 1 C3850(config-pmap-c)# queue-buffers ratio 10 ! C3850(config-pmap-c)# class class-default C3850(config-pmap-c)# bandwidth remaining percent 25 C3850(config-pmap-c)# queue-buffers ratio 25 ! C3850(config)# interface gigabitethernet 1/0/x C3850(config-if)# service-policy out 1P7Q3T
- 2P6Q3T : This model only differ slightly from the previous one as it has been extended to cover 12-class model & the addition of a second priority queue for seperation for voice & video. Below diagram shows the 2P6Q3T egress queue mapping for catalyst 3850.
Below show the corresponding configuration for an 12-class 2P6Q3T egress queuing on a 3850.
C3850(config-pmap-c)# policy-map 2P6Q3T C3850(config-pmap)# class VOICE C3850(config-pmap-c)# priority level 1 C3850(config-pmap-c)# police rate percent 10 ! C3850(config-pmap-c)# class RT-VIDEO C3850(config-pmap-c)# priority level 2 C3850(config-pmap-c)# police rate percent 20 ! C3850(config-pmap-c-police)# class MGT-CONTROL C3850(config-pmap-c)# bandwidth remaining percent 10 C3850(config-pmap-c)# queue-buffers ratio 10 ! C3850(config-pmap-c)# class MULTIMEDIA-CONFERENCE C3850(config-pmap-c)# bandwidth remaining percent 10 C3850(config-pmap-c)# queue-buffers ratio 10 C3850(config-pmap-c)# queue-limit dscp af43 percent 80 C3850(config-pmap-c)# queue-limit dscp af42 percent 90 C3850(config-pmap-c)# queue-limit dscp af41 percent 100 ! C3850(config-pmap-c)# class MULTIMEDIA-STREAMING C3850(config-pmap-c)# bandwidth remaining percent 10 C3850(config-pmap-c)# queue-buffers ratio 10 C3850(config-pmap-c)# queue-limit dscp af33 percent 80 C3850(config-pmap-c)# queue-limit dscp af32 percent 90 C3850(config-pmap-c)# queue-limit dscp af31 percent 100 ! C3850(config-pmap-c)# class TRANSACTIONAL-DATA C3850(config-pmap-c)# bandwidth remaining percent 10 C3850(config-pmap-c)# queue-buffers ratio 10 C3850(config-pmap-c)# queue-limit dscp af23 percent 80 C3850(config-pmap-c)# queue-limit dscp af22 percent 90 C3850(config-pmap-c)# queue-limit dscp af21 percent 100 ! C3850(config-pmap-c)# class BULK-SCAVENGER C3850(config-pmap-c)# bandwidth remaining percent 5 C3850(config-pmap-c)# queue-buffers ratio 10 C3850(config-pmap-c)# queue-limit dscp af13 percent 80 C3850(config-pmap-c)# queue-limit dscp af12 percent 90 C3850(config-pmap-c)# queue-limit dscp af11 percent 100 ! C3850(config-pmap-c)# class class-default C3850(config-pmap-c)# bandwidth remaining percent 25 C3850(config-pmap-c)# queue-buffers ratio 25 ! C3850(config)# interface gigabitethernet 1/0/x C3850(config-if)# service-policy out 2P6Q3T
2. Wireless Queuing
- 2P2Q : The wireless queuing model is a 4 queue structure of which two are strict priority using for Voice & Video.The other queues are “class-default” or NRT (Non-Real-Time) & Multicast Queue (non-client-nrt-class). If your multicast traffic is marked as CS5, then it will go to the priority queue, so only multicast traffic marked as non-real time goes into this queue.
When scheduling, strict priority queues are fully serviced ahead of all other queues. When configuring more then one priority queue, only when the first priority queue has been fully serviced, scheduler will go to the 2nd priority queue. A strict priority queue is enabled with the “priority level x” command in policy map configuration.
For the other two queues (class-default & non-client-ntr-class) scheduling is based on CBWFQ (Class Based Weighted Fair Queue). Below diagram illustrates this.
Approximate Fair Drop (AFD) is the bandwidth control algorithm used to control bandwidth allocation among classes that share the class-default queue of wireless interface. AFD provides fairness between clients by calculating virtual queue lengths at the radio, SSID & client levels.These virtual queue lengths trigger probabilistic drops at the client level for clients that are consuming greater than the fair share of bandwidth. Below diagram illustrates AFD concept
Below diagram shows 2P2Q wireless egress queuing model.
You can verify the policy-map configurations available on your 3850 switch using “show policy-map” command. As you can see “port_child_policy” policy-map is there with 10% bandwidth allocation to “non-client-nrt-class” class.
3850-2#show policy-map
Policy Map port_child_policy
Class non-client-nrt-class
bandwidth remaining ratio 10
Let’s define two class maps named “VOICE” & “VIDEO” which will match DSCP “ef” & “af41” respectively. Then we will allocate 10% & 20% for those traffic & make them go via priority queues as shown in the above 2P2Q model. Also allocate 60% of the bandwidth for the “class-default” class.
3850-2(config)#class-map VOICE 3850-2(config-cmap)#match dscp ef ! 3850-2(config-pmap)#class-map VIDEO 3850-2(config-cmap)#match dscp af41 ! 3850-2(config-cmap)#policy-map port_child_policy 3850-2(config-pmap)#class VOICE 3850-2(config-pmap-c)#? Policy-map class configuration commands: admit Admit the request for bandwidth Bandwidth exit Exit from QoS class action configuration mode netflow-sampler NetFlow action no Negate or set default values of a command police Police priority Strict Scheduling Priority for this Class queue-buffers queue buffer queue-limit Queue Max Threshold for Tail Drop service-policy Configure QoS Service Policy set Set QoS values shape Traffic Shaping <cr> 3850-2(config-pmap-c)#priority ? <8-10000000> Kilo Bits per second level Multi-Level Priority Queue percent % of total bandwidth <cr> 3850-2(config-pmap-c)#priority level 1 3850-2(config-pmap-c)#police ? <8000-10000000000> Target Bit Rate (bits per second) (postfix k, m, g optional; decimal point allo cir Committed information rate rate Specify police rate, PCR for hierarchical policies or SCR for single-level ATM 4.0 policer policies 3850-2(config-pmap-c)#police rate percent 10 conform-action transmit exceed-action drop 3850-2(config-pmap)#class VIDEO 3850-2(config-pmap-c)#priority level 2 3850-2(config-pmap-c)#police rate percent 20 conform-action transmit exceed-action drop 3850-2(config-pmap)#class class-default 3850-2(config-pmap-c)#bandwidth remaining ratio ? <1-100> Ratio 3850-2(config-pmap-c)#bandwidth remaining ratio 60
This policy map is applied automatically by the WCM (Wireless Control Module) to all wireless ports (a port where an AP is directly attached). You can verify the policy configuration using “show policy-map” command.
3850-2#sh policy-map port_child_policy Policy Map port_child_policy Class non-client-nrt-class bandwidth remaining ratio 10 Class VOICE priority level 1 police rate percent 10 conform-action transmit exceed-action drop Class VIDEO priority level 2 police rate percent 20 conform-action transmit exceed-action drop Class class-default bandwidth remaining ratio 60
You can verify this policy is applied to wireless ports automatically. In my case I have two APs connected to G1/0/1 & G1/0/2(so those are wireless ports). You can see the Radio & AP level QoS as shown below (since they automatically applied).
3850-2#sh ap summary Number of APs: 2 Global AP User Name: Not configured Global AP Dot1x User Name: Not configured AP Name AP Model Ethernet MAC Radio MAC State ---------------------------------------------------------------------------------------- L3702-1 3702I 7cad.74ff.2bc6 08cc.68b4.0370 Registered L3602-1 3602I 4c00.82df.a4c1 f84f.57e3.1460 Registered 3850-2#sh cdp nei Device ID Local Intrfce Holdtme Capability Platform Port ID L3602-1 Gig 1/0/2 125 R T AIR-CAP36 Gig 0.1 L3702-1 Gig 1/0/1 142 R T AIR-CAP37 Gig 0.1 3850-2#show policy-map interface wireless ap name L3602-1 AP L3602-1 iifid: 0x0105EE400000000A Service-policy output: defportangn Class-map: class-default (match-any) Match: any 0 packets, 0 bytes 30 second rate 0 bps Queueing (total drops) 0 (bytes output) 4165972 shape (average) cir 600000000, bc 2400000, be 2400000 target shape rate 600000000 Service-policy : port_child_policy queue stats for all priority classes: Queueing priority level 1 (total drops) 0 (bytes output) 1376223 queue stats for all priority classes: Queueing priority level 2 (total drops) 0 (bytes output) 4078 Class-map: non-client-nrt-class (match-any) Match: non-client-nrt 0 packets, 0 bytes 30 second rate 0 bps Queueing (total drops) 0 (bytes output) 2845227 bandwidth remaining ratio 10 Class-map: VOICE (match-any) Match: dscp ef (46) 0 packets, 0 bytes 30 second rate 0 bps Priority: Strict, Priority Level: 1 police: rate 10 % rate 60000000 bps, burst 1875000 bytes conformed 188116 bytes; actions: transmit exceeded 0 bytes; actions: drop conformed 0 bps, exceeded 0 bps Class-map: VIDEO (match-any) Match: dscp af41 (34) 0 packets, 0 bytes 30 second rate 0 bps Priority: Strict, Priority Level: 2 police: rate 20 % rate 120000000 bps, burst 3750000 bytes conformed 0 bytes; actions: transmit exceeded 0 bytes; actions: drop conformed 0 bps, exceeded 0 bps Class-map: class-default (match-any) Match: any 0 packets, 0 bytes 30 second rate 0 bps Queueing (total drops) 0 (bytes output) 128304 bandwidth remaining ratio 60 3850-2#show policy-map interface wireless radio Radio dot11b iifid: 0x0105EE400000000A.0x00D003000000000B Service-policy output: def-11gn Class-map: class-default (match-any) Match: any 0 packets, 0 bytes 30 second rate 0 bps shape (average) cir 200000000, bc 800000, be 800000 target shape rate 200000000 Radio dot11a iifid: 0x0105EE400000000A.0x00CD6AC00000000C Service-policy output: def-11an Class-map: class-default (match-any) Match: any 0 packets, 0 bytes 30 second rate 0 bps shape (average) cir 400000000, bc 1600000, be 1600000 target shape rate 400000000 Radio dot11b iifid: 0x010605C000000008.0x00CC838000000004 Service-policy output: def-11gn Class-map: class-default (match-any) Match: any 0 packets, 0 bytes 30 second rate 0 bps shape (average) cir 200000000, bc 800000, be 800000 target shape rate 200000000 Radio dot11a iifid: 0x010605C000000008.0x00CCB74000000005 Service-policy output: def-11ac Class-map: class-default (match-any) Match: any 0 packets, 0 bytes 30 second rate 0 bps shape (average) cir 1000000000, bc 4000000, be 4000000 target shape rate 1000000000
In next post we will see how to configure QoS on switchport where they play different roles & how to verify those configuration.
References
1. End to End QoS Design- Quality of Service for Rich-Media & Cloud Networks (2nd Edition)
2. BRKCRS-2890 Converged Access QoS
3. BRKCRS-2501: Campus QoS Design—Simplified
Related Posts
1. 3850 QoS – Part 1 (QoS Touch Points)
2. 3850 QoS – Part 3 (Port Specific QoS Role)
3. 3850 QoS – Part 4 (Wireless QoS Mapping)
4. 3850 QoS – Part 5 (Traffic Classification)
Hi, first of all thanks for this great article regarding QoS for the 3850. I just have an inquiry regarding 1P7Q3T, if I use that, will I be tied to using 8 exact classes of traffic? I’m actually trying to migrate QoS from 3750 to 3850, and currently our implementation on the 3750 contains10 classes of traffic. Thanks in Advance for your response!!!
Yes, you can define max 8 class-maps. But you can classify different traffic onto single class by using multiple match statements.
In your case you need to consolidate few classes if you are using 1P7Q3T model.
HTH
Rasika
Hi again, Just to clarify, since this is just a suggested QoS model. I will be actually allowed to modify it, like create 10 class-maps and just adjust the necessary bandwidth to make it total to 100%. Will that work? Thanks again!
Since in hardware level only 8 queues available for a 3850 switchport , when you configuring classes under service policy it will allocate a queue to each traffic class. So to have more classes than the number of queues available makes no sense.
I would expect you are not allow to define more than 8 classes under servicy policy (even if it allows, then multiple classes traffic have to go into single queue at hardware level)
HTH
Rasika
Pingback: 3850 QoS – Part 3 (Port Specific QoS Role) | ytd2525
Hi again, thanks for the help on this.
Follow-up question, in your 1P7Q3T egress queuing example and as stated in your blog.
Queueing is applied thru service-policy now, unlike before where in we use the command priority-queue-out on a egress switchport.
New:
C3850(config)# interface gigabitethernet 1/0/x
C3850(config-if)# service-policy out 1P7Q3T
My question now is, can I apply another service-policy (service-policy input) for marking? Is that the correct implemenation? coz in the past, the config is like the below.
So now, my idea is there needs to be 2 policy maps created (1st for egress / 2nd your normal policy-map for marking traffic) But I read somewhere that I can only apply a policy-map in 1 direction. Please correct me if I’m wrong.
Old:
interface GigabitEthernet1/0/2
priority-queue out (will enable the outbound priority queue for this interface)
service-policy input MARKING (example policy applied inbound for marking traffic)
If it would not be too much to ask favor on this, can you give me like a sample working complete QOS config for a 3850, I would really appreciate it. Thanks again!
Yes, classification service policy you can apply input direction as you do in the old switch platforms.
You are correct in the above. Classification service policy ingress & queuing service policy on egress.
HTH
Rasika
Hi, Sorry to bother you again. May I ask if you can check if my proposed QOS converstion to a 3850 is OK. part 1 is the existing 3750x QOS, then part 2 is the proposed QOS converstion for a new 3850 switch. Many Thanks!
—————————————————————————————————————–
Part 1 – *** (3750x existing QOS) Classification Service Policy Ingress & Egress Queueing
!
class-map match-all CM-Best-Effort
match ip dscp default
class-map match-any CM-Critical-Data
match ip dscp af41 af42 af43
class-map match-any CM-Network-Control
match ip dscp cs6 cs7
class-map match-any CM-Business-Data
match ip dscp af11 af12 af13
class-map match-all Best-Effort
match access-group name Best-Effort
class-map match-all Critical-Data
match access-group name Critical-Data
class-map match-all Business-Data
match access-group name Business-Data
class-map match-all Voice
match ip dscp ef
class-map match-all CM-Voice
!
policy-map MARKING
class Critical-Data
set dscp af41
class Business-Data
set dscp af11
class Best-Effort
set dscp default
class Voice
set dscp ef
!
interface [interface]
srr-queue bandwidth share 1 40 45 14
srr-queue bandwidth shape 0 0 0 0
priority-queue out
mls qos trust dscp
service-policy input MARKING
!
mls qos map cos-dscp 0 8 16 24 32 46 48 56
mls qos srr-queue input bandwidth 70 30
mls qos srr-queue input threshold 1 80 90
mls qos srr-queue input priority-queue 2 bandwidth 30
mls qos srr-queue input dscp-map queue 1 threshold 2 24
mls qos srr-queue input dscp-map queue 1 threshold 3 48 56
mls qos srr-queue input dscp-map queue 2 threshold 3 32 40 46
mls qos srr-queue output dscp-map queue 1 threshold 2 48 56
mls qos srr-queue output dscp-map queue 1 threshold 3 46
mls qos srr-queue output dscp-map queue 2 threshold 3 34 36 38
mls qos srr-queue output dscp-map queue 3 threshold 2 12 14
mls qos srr-queue output dscp-map queue 3 threshold 3 10
mls qos srr-queue output dscp-map queue 4 threshold 1 8
mls qos srr-queue output dscp-map queue 4 threshold 2 0 1 2 3 4 5 6 7
mls qos srr-queue output dscp-map queue 4 threshold 2 9 11 13
mls qos srr-queue output dscp-map queue 4 threshold 3 15 16 17 18 19 20 21 22
mls qos srr-queue output dscp-map queue 4 threshold 3 23 24 25 26 27 28 29 30
mls qos srr-queue output dscp-map queue 4 threshold 3 31 32 33 35 37 39 40 41
mls qos srr-queue output dscp-map queue 4 threshold 3 42 43 44 45 47 49 50 51
mls qos srr-queue output dscp-map queue 4 threshold 3 52 53 54 55 57 58 59 60
mls qos srr-queue output dscp-map queue 4 threshold 3 61 62 63
mls qos queue-set output 1 threshold 1 150 300 100 1000
mls qos queue-set output 1 threshold 2 150 300 100 1000
mls qos queue-set output 1 threshold 3 150 300 50 1000
mls qos queue-set output 1 threshold 4 100 300 66 1000
mls qos queue-set output 1 buffers 10 30 20 40
mls qos
!
————————————————————————————————————-
Part 2 – *** (Proposed 3850 QOS Conversion )
-Classification Service Policy Ingress (retain from 3750x existing QOS))
-Egress Queueing (define 1 new policy-map for Egress Queueing implementation)
policy-map 1P7Q3T-EGRESS-QUEUEING
class-map match-all VOICE-QUEUE
match ip dscp ef
class-map match-any NW-CONTROL-QUEUE
match ip dscp cs6 cs7
class-map match-any INTERACTIVE-VIDEO-QUEUE
match ip dscp af41 af42 af43
class-map match-any SIGNALING-QUEUE
match ip dscp cs3
class-map match-any STREAMING-VIDEO-QUEUE
match ip dscp af31 af32 af33
class-map match-any CRITICAL-DATA-QUEUE
match ip dscp af21 af22 af23
class-map match-any BUSINESS-DATA-QUEUE
match ip dscp af11 af12 af13
class-map match-any class-default
match ip dscp default
!
policy-map 1P7Q3T-QUEUE
class VOICE-QUEUE
priority level 1
police rate percent 30
class NW-CONTROL-QUEUE
bandwidth remaining percent 5
queue-buffers ratio 10
class INTERACTIVE-VIDEO-QUEUE
bandwidth remaining percent 23
queue-buffers ratio 10
queue-limit dscp af43 percent 80
queue-limit dscp af42 percent 90
queue-limit dscp af41 percent 100
class SIGNALING-QUEUE
bandwidth remaining percent 2
class STREAMING-VIDEO-QUEUE
bandwidth remaining percent 10
queue-buffers ratio 10
queue-limit dscp af33 percent 80
queue-limit dscp af32 percent 90
queue-limit dscp af31 percent 100
class CRITICAL-DATA-QUEUE
bandwidth remaining percent 30
queue-buffers ratio 10
queue-limit dscp af23 percent 80
queue-limit dscp af22 percent 90
queue-limit dscp af21 percent 100
class BUSINESS-DATA-QUEUE
bandwidth remaining percent 1
queue-buffers ratio 10
class class-default-QUEUE
bandwidth remaining percent 25
queue-buffers ratio 25
!
interface [interface]
service-policy input MARKING
service-policy output 1P7Q3T-EGRESS-QUEUEING
Hi, Is egress queueing suggested only to be applied to uplink/trunk ports? Or is it still needed to be applied on access ports ?
Hi Jonathan,
I would apply it for all the ports including access ports.
Regards
Rasika
Hi,
It’s really a good article. I’m setting up 3850 for iSCSI only for Equallogic SAN and i know dell has suggested the following mls qos commnds on 3750, but as 3850 doesn’t support mls qos command. Can you please help me with an equivalent config on 3850. below are the QOS commands on 3750.
switch(config)#mls qos queue-set output 1 buffers 4 88 4 4
switch(config)#mls qos queue-set output 1 threshold 1 100 100 100 400
switch(config)#mls qos queue-set output 1 threshold 2 3200 100 10 3200
switch(config)#mls qos queue-set output 1 threshold 3 100 100 100 400
switch(config)#mls qos queue-set output 1 threshold 4 100 100 100 400
Also As i don’t use this switch for any Wireless in this case. Do you know how i can clear up the default wireless related stuff from the 3850 switch? leaving the default config as it is effect my iSCSI?. I really appreciate your help.
thanks
raj
Hi Raj,
Did not have time to look at this in detail.
Regarding wireless stuff, by default it is not enabled. So you do not want to do anything on that.
HTH
Rasika
I will be replacing our 3750x stack with a couple of 3850’s and was just wondering if I have to use and configure all 8 queues or can I just model the 4 queues similar to what we have on our 3750’s? Also I believe I will have to setup an output policy since 3850’s doesn’t support SRR for egress queueing, will I have to create class-maps for all the classification where on the 3750’s it is configured on the port such as “srr-queue bandwidth shape 8 0 0 0”?
We will also have AP’s and a wireless controller on these new switches. Will wireless traffic automatically use the default QoS since we are not using the wireless controller portion of the switch?
You can use 4 queue models if you want.In that case you need to define your class maps accordingly to use those 4 queues.
By default these switches trust DSCP or CoS depend on the switch port configuration. So AP connected switchport will trust DSCP as those configured as access port & WLC connneTrunk.
If you are not using WLC functionality of the switch then you cannot apply same QoS policy for wired & wireless as traffic from AP to WLC will be CAPWAP encapsulated.
HTH
Rasika
Hello Rasika,
Great detailed posts and informative resource!
If possible, I just would like to recap on the following and confirm my understanding :
A) Choosing the correct % value for each class
For example 1P7Q3T model we can see :
Voice EF = 10%
Network Control CS6 = 5%
Interactive Video AF41 = 23%
And so forth…
then I need to apply the following values to each class as follows: – example :
class VOICE
police rate percent 10
class NW-CONTROL
bandwidth remaining percent 5
class INT-VIDEO
bandwidth remaining percent 23
Hope i understand this correctly 🙂
B) Ratio:
The ratio command ( queue-buffers ratio ) has been already pre-set and you have explained that the values 10, 10 etc..through 25 are Cisco recommended values
I read that the QUEUE BUFFER ALLOCATION can be tuned using the “queue-buffers ratio ” command
C) queue-limit dscp xx percent x
Looking at this example,
Whilst the bandwidth remaining percent 23 command stipulates how frequently a Queue is services, the queue-limit dscp xx percent x
command does do the following according to my understanding: see comments below:
Your example:
class INT-VIDEO
bandwidth remaining percent 23
queue-buffers ratio 10
queue-limit dscp af43 percent 80
>Drop packets with af43 label first if class Q INT-VIDEO reached 80%
queue-limit dscp af42 percent 90
>Drop packets with af42 ladled second if class Q INT-VIDEO reached 90%
queue-limit dscp af41 percent 100
> Drop all af 4x label packets
Just to recap my understanding :
a) BUFFER and QUEUES has nothing to do with each other
b) You can define 7 Queues with the 1P7Q3T queuing model
c) Each Queue sizing parameters should be optioned for the specific 1P7Q3T queuing model.
Example : Network Control CS6 = 5% or Interactive Video AF41 = 23%
d) BANDWIDTH per cent command states how often a Queue get serviced
e) QUEUE BUFFER ALLOCATION can be tuned using the “queue-buffers ratio ” command
I trust that this post is in order.
Best wishes
Markus
Hello again Raskia,
Fantastic resource and i have ordered the recommended Qos book.
Just one query to the Signalling allocation.
You wrote:
1P7Q3T for Wired; The recommended buffer allocation for wired interface queue 7 to 1 are 10:10:10:10:10:10:25 in percentage (%).
— un quote —
This would mean that all queues from Network Control (queue 7) through class-class default (queue 1)
receive the recommended buffer ratio values.
I just queried this as the signalling class in your post does not show the buffer ratio 10:) (sorry, i am not looking for mistakes here just try to fully learn and understand the subject. Again your resources are amazing!
class NW-CONTROL – > ratio 10
class INT-VIDEO – > ratio 10
class SIGNALING – > ratio 10 (this is currently not showing )
class STREAMING-VIDEO – > ratio 10
class CRITICAL-DATA – > ratio 10
class SCAVENGER – > ratio 10
class class-default – > ratio 25
Many thanks
Best Wishes
Markus
Pingback: Cisco iOS | KB
Hi Rasika,
according to your below configuration, can you please define the class map configuration that you are using, and also shall we apply this policy map on access and trunk port and in which directions? and what to do on the distribution switches if it is a catalyst 6800.???
C3850(config-pmap-c)# policy-map 1P7Q3T
C3850(config-pmap)# class VOICE
C3850(config-pmap-c)# priority level 1
C3850(config-pmap-c)# police rate percent 10
!
C3850(config-pmap-c-police)# class NW-CONTROL
C3850(config-pmap-c)# bandwidth remaining percent 5
C3850(config-pmap-c)# queue-buffers ratio 10
!
C3850(config-pmap-c)# class INT-VIDEO
C3850(config-pmap-c)# bandwidth remaining percent 23
C3850(config-pmap-c)# queue-buffers ratio 10
C3850(config-pmap-c)# queue-limit dscp af43 percent 80
C3850(config-pmap-c)# queue-limit dscp af42 percent 90
C3850(config-pmap-c)# queue-limit dscp af41 percent 100
!
C3850(config-pmap)# class SIGNALING
C3850(config-pmap-c)# bandwidth remaining percent 2
!
C3850(config-pmap-c)# class STREAMING-VIDEO
C3850(config-pmap-c)# bandwidth remaining percent 10
C3850(config-pmap-c)# queue-buffers ratio 10
C3850(config-pmap-c)# queue-limit dscp af33 percent 80
C3850(config-pmap-c)# queue-limit dscp af32 percent 90
C3850(config-pmap-c)# queue-limit dscp af31 percent 100
!
C3850(config-pmap-c)# class CRITICAL-DATA
C3850(config-pmap-c)# bandwidth remaining percent 24
C3850(config-pmap-c)# queue-buffers ratio 10
C3850(config-pmap-c)# queue-limit dscp af23 percent 80
C3850(config-pmap-c)# queue-limit dscp af22 percent 90
C3850(config-pmap-c)# queue-limit dscp af21 percent 100
!
C3850(config-pmap-c)# class SCAVENGER
C3850(config-pmap-c)# bandwidth remaining percent 1
C3850(config-pmap-c)# queue-buffers ratio 10
!
C3850(config-pmap-c)# class class-default
C3850(config-pmap-c)# bandwidth remaining percent 25
C3850(config-pmap-c)# queue-buffers ratio 25
!
C3850(config)# interface gigabitethernet 1/0/x
C3850(config-if)# service-policy out 1P7Q3T
thanks,
Haitham Jneid
How to divide 3850 queuing (1p 7q 3t) if i use only 5 classes and class-default(total 6 classes)