In this post we will see how multicast can be configured on WGB (workgroup bridge) solution. Here is the topology for this post. WGB (3502I) is connected to Autonomous AP (AAP2- 1131), where a wireled client (multicast receiver) is connected behind WGB. A multicast source is connected to L3 switch where all the SVI & DHCP pool defined.(VLC player is used to simulate multicast streaming & receving it at the other end)
AAP2 is connected to C3750 Fa1/0/12 which is configured as trunk port with native vlan 999.
interface FastEthernet1/0/11 switchport trunk encapsulation dot1q switchport trunk native vlan 999 switchport trunk allowed vlan 1,6,999 switchport mode trunk priority-queue out mls qos trust cos
Here is the config of Root AP (AAP1)
hostname AAP2
!
dot11 ssid WGB
vlan 999
authentication open
!
interface Dot11Radio1
ssid WGB
station-role root
!
interface Dot11Radio1.999
encapsulation dot1Q 999 native
bridge-group 1
!
interface FastEthernet0.999
encapsulation dot1Q 999 native
bridge-group 1
!
interface BVI1
ip address 192.168.99.199 255.255.255.0
!
ip default-gateway 192.168.99.1
Here is the config of WGB.
hostname WGB
!
dot11 ssid WGB
authentication open
!
interface Dot11Radio1
ssid WGB
station-role workgroup-bridge
bridge-group 1
!
interface GigabitEthernet0
bridge-group 1
!
interface BVI1
ip address 192.168.99.100 255.255.255.0
Once you configure this you should see the WGB & its client association on AAP1 like below.
AAP2#sh dot11 associations
802.11 Client Stations on Dot11Radio1:
SSID [WGB] :
MAC Address IP address Device Name Parent State
001f.1618.dfec 192.168.99.207 WGB-client - 44d3.caaf.4343 Assoc
44d3.caaf.4343 192.168.99.100 WGB WGB self Assoc
Now it is ready to test your multicast, I am streaming a video from PC1 to multicast group address 238.2.3.8 & then from PC2 behind the WGB, joining to this group. Now if you do a wireless packet capture you could see the traffic going to across this link. Here is a sample output of that capture.
If you look at one individual packet in detail it will looks like this
You can see in the wireless frame header there are 4 different address (Receiver, Destination, Transmitter – AAP1 & Source – PC1). But both Receiver address & Destination address is same as the multicast MAC address. In other words these multicast frames are not acknowledged by WGB, so reliability of packet delivery cannot be ensured.
You can improved the reliability of multicast packet delivery by configuring WGB as infrastructure-client instead of normal client. You have to configure “infrastructure-client” command on root AP (AAP2) radio interface.
AAP2
interface Dot11Radio1
infrastructure-client
Let’s see the difference it makes this time.
This time you can see each multicast frame is acknowledge by WGB. Here is the inside of a multicast packet this time.
You can see this time Receiver address is WGB mac address, so it is a unicast frame where WGB will acknowledge every time. The advantage is that if you have several clients behind the WGB, you send one broadcast (or one multicast), then a second copy of that broadcast/multicast encapsulated into a unicast frame to the WGB and the ACK from the WGB confirms that the frame was received and is going to be relayed to the wired clients. This increases reliability (usually, broadcasts and multicasts are never acknowledged)..
The downside is that it also increases traffic on the radio, as packets that are usually not acknowledged are now acknowledged (and you send as many unicast copies as you have WGBs). So the limitation of this mode is that the AP will not allow more than 20 WGB clients.
Normally in this scenario WGB receive same multicast frame twice. You can configure the workgroup bridge multicast mode to either “client” or “infrastructure” mode. If you configure it as “infrastructure” it will only accept 4 different MAC address frames & drop 3 MAC address frames (where destination & receiver address identical).
WGB(config-if)#station-role workgroup-bridge ? multicast configure multicast universal Universal Client <cr> WGB(config-if)#station-role workgroup-bridge multicast ? mode configure multicast mode WGB(config-if)#station-role workgroup-bridge multicast mo WGB(config-if)#station-role workgroup-bridge multicast mode ? client Client-mode accepts only 3-MAC address header mulitcast packets infrastructure Infrastructure-mode accepts only 4-MAC address header multicast packets WGB(config-if)#station-role workgroup-bridge multicast mode client *Jul 6 19:55:34.932: %DOT11-4-UPLINK_ESTABLISHED: Interface Dot11Radio1, Associated To AP AAP2 0019.a945.fb00 *Jul 6 19:55:35.526: %DOT11-6-MCAST_DISCARD: infrastructure mode multicast packets are discarded in client mode multicast mode WGB(config-if)#station-role workgroup-bridge multicast mode infrastructure
In a future post we will see how we can do this when WGB is connected to Light Weight Access point as root.
Related Posts
1. Test Yourself- Basic Multicast
2. Configuring Multicast on WLC
3. Wireless Multicast is not working – Why ?
4. Understanding “VideoStream” feature
5. IGMP Basics
6. Multicast Address Allocation
7. Multicast Deployment Types
8. PIM-SM Static RP Configurations
9. PIM-SM Auto-RP configurations
10. PIM-BSR Bootstrap Router Configurations
11. Anycast with MSDP
12. PIM-SSM Source Specific Multicast
Hello Nayarasi do we have to allow vlan 999 or can we exclude it switchport trunk allowed vlan 1,6,999Regards Jose T Perez
Date: Fri, 9 Aug 2013 11:30:01 +0000 To: jose_tomas_perez@hotmail.com
Since vlan999 is native (& not tagged) you can exclude it from allow vlan list. It should work.
In my case, there are no any other switch ports in vlan 999, so I have to pass it on this AAP1 trunk to bring interface vlan 999 up.
HTH
Rasika
Hi Rasika,
Best of luck for your lab. Hope you keep these blogs going after you pass :).
Regards,
Nikhil
Thanks Nikhil,
yes I will keep it up… I realized lot of people following it (since not many good materials for this track to someone to study)
For me, this blog became the conduit to establish relationship with rest of the world & I like that (never thought I would get such incredible outcome)
Regards
Rasika
Hi,
Have you made the post for WGB with LW as root ?
Hi Rasika,
you wrote “In a future post we will see how we can do this when WGB is connected to Light Weight Access point as root.”
But I cannot find any related post, and I think this is not possible at all. If I am wrong, please can you explain how this should work? (make reliable MC with WGB connected to lightweight AP as root).
I only found the following post where you commented “In lightweight AP as root, WGB in infrastructure mode is not supported.”
https://mrncciew.com/2013/04/30/wgb-with-capwap/
If there is another way for making reliable MC with CAPWAP (even without infrastructure-ssid) please let me know.
Many thanks!
Best regards,
Mark
Hi Mark,
sorry, i do not think i was able to do such a post
Rasika
OK thanks for your reply.